Difference between revisions of "Audacity FAQ"

From Librivox wiki
Jump to: navigation, search
(How can I merge multiple tracks into a single one?)
(How do I configure Audacity to find and use the LAME encoder plug-in?)
 
(13 intermediate revisions by 5 users not shown)
Line 21: Line 21:
 
# Audio I/O Tab > Channels > 1 (Mono) ... [http://www.flickr.com/photos/osmia/69706045/in/pool-librivox-pics/ example]
 
# Audio I/O Tab > Channels > 1 (Mono) ... [http://www.flickr.com/photos/osmia/69706045/in/pool-librivox-pics/ example]
 
# Quality > Default Sample Rate: 44100 Hz
 
# Quality > Default Sample Rate: 44100 Hz
# Quality > Default Sample Format: 16-bit float
+
# Quality > Default Sample Format: 16-bit
 
# Save your preferences by clicking OK
 
# Save your preferences by clicking OK
 
How to set your preferences
 
How to set your preferences
Line 32: Line 32:
 
# Start Audacity
 
# Start Audacity
 
# <b>Edit > Preferences</b>
 
# <b>Edit > Preferences</b>
## If using Audacity 1.2.6: <b>File Formats</b> Tab > <b>MP3 Export Setup<b>
+
## <b>Import/Export</b> tag > <b>MP3 Export Library</b>
## If using Audacity 1.3: <b>Import/Export</b> tag > <b>MP3 Export Library</b>
 
 
# Click <b>Find Library</b>
 
# Click <b>Find Library</b>
 
# Read the message, then click <b>Yes</b> and browse to wherever you installed the file <b>lame_enc.dll</b>
 
# Read the message, then click <b>Yes</b> and browse to wherever you installed the file <b>lame_enc.dll</b>
# Select the file, and click the </b>OK</b> button
+
# Select the file, and click the <b>OK</b> button
## If using Audacity 1.2.6: Choose <b>128</b> from the drop down menu.
+
## Set the bitrate the first time you export to mp3 by going to:
## If using Audacity 1.3, you'll set the bitrate the first time you export to mp3 by going to:
 
 
### <b>File > Export</b>
 
### <b>File > Export</b>
 
### Save as type: <b>MP3 Files</b>
 
### Save as type: <b>MP3 Files</b>
### <b>Options...</b> (below the cancel button)
+
### <b>Format Options...</b> (below the cancel button)
 +
### <b>Bit Rate Mode</b> > select the <b>Constant</b> radio button
 
### <b>Quality</b> > select <b>128 kbps</b> from the drop down menu
 
### <b>Quality</b> > select <b>128 kbps</b> from the drop down menu
 
### <b>OK > Save</b>
 
### <b>OK > Save</b>
Line 59: Line 58:
 
# Delete the selected portion of your recording.  Hit the "Delete" key on your keyboard.
 
# Delete the selected portion of your recording.  Hit the "Delete" key on your keyboard.
  
(You might want to look at [[Deleting errors in Audacity]], too.)
+
(You might want to look at [[Deleting Errors in Audacity]], too.)
 
 
== How do I edit the ID3 tag? ==
 
It's important to set the ID3 tags properly.  These are used by MP3 players to identify the recording.
 
# <b>Project > Edit ID3 Tags ...</b> [http://www.flickr.com/photos/osmia/70081674/in/pool-librivox-pics/ example]
 
# <b>Edit ID3 Tags (for MP3 exporting) ...</b> [http://www.flickr.com/photos/osmia/70081675/in/pool-librivox-pics/ example]
 
  
 
== Can I clean up background noise? ==
 
== Can I clean up background noise? ==
  
'''Go here for the --> Audacity [[Noise Cleaning]] Tutorial'''
+
Go here for the --> Audacity [[Noise Cleaning]] Tutorial
  
'''Note: Please save a backup copy of your file prior to applying Noise Removal filters so that you can revert to the original if results are not as expected.'''
+
== Should I record in Mono or Stereo? ==
 +
Audacity allows you to choose Stereo or Mono when you start your recording. Since most of us don't use Stereo microphones, choose Mono. When you export the file it will end up playing back in Stereo. Recording in Mono just instructs Audacity to apply the same content to both left and right.
  
Using Audacity version 1.3 or higher, select a portion of the room noise (this is for applying the noise removal filter).  Normally, what you would do is this:
+
== Why does my MP3 export as Stereo, when I am recording in Mono? ==
# <b>Effect > Noise Removal</b> and click on the <b>Noise Profile</b> button
+
First make absolutely sure that you have set your recording preferences as Mono in Edit | Preferences | Devices | Recording | Channels, and that you have selected Joint Stereo as the Channel mode in the Options when you export the MP3.  
# Select your entire recording, then <b>Effect > Noise Removal</b> and click <b>Apply</b>. You can select sections or all of the recording by:
 
## Clicking and dragging
 
## Choosing <b>Edit > Select</b> from the menu bar.
 
This will leave a strange whispering sound in the background; like a ghostly murmur, the kind you might want to use as a background noise in a horror movie.  So, that's '''not''' what you're going to do.
 
:'''Instead:'''
 
# With the section of the room noise selected, use Effect > Amplify
 
# In the amplification, use anywhere from -3 to -6db to decrease the amplitude of the noise wave.
 
# Now, use this for the "Noise Profile" and apply to the whole recording (as above).  When actually doing the noise removal, use a very low setting on the slide-bar.
 
You will have to experiment for best results.  I can take a fairly noisy microphone (one I got from Radio Shack) and produce fairly clean recordings this way.
 
  
 
+
If both of these are correct, and you are still told that your MP3 is Stereo, there is only one explanation that we have found: in Audacity, you will see a slider to the left of your mono track which looks like this: [[File:Leftright.png]]. If this is not correctly centred, then (for some inexplicable reason) Audacity will export your MP3 as a Stereo file.
 
 
== Should I record in Mono or Stereo? ==
 
Audacity allows you to choose Stereo or Mono when you start your recording. Since most of us don't use Stereo microphones, choose Mono. When you export the file it will end up playing back in Stereo. Recording in Mono just instructs Audacity to apply the same content to both left and right.
 
  
 
== How can I merge multiple tracks into a single one? ==
 
== How can I merge multiple tracks into a single one? ==
  
If you want to add background sounds or create a crowd scene: *[[Merging Tracks]]
+
If you want to add background sounds or create a crowd scene: [[Merging Tracks]]
  
 
== Additional Resources ==
 
== Additional Resources ==
Some additional guides on how to use Audacity (''links working as of 2009 March''):
+
Some additional guides on how to use Audacity (''links working as of 2009 March''):
  
  * [http://audacity.sourceforge.net/help/ Official Audacity Help Page] - includes FAQ, tips, and tutorials.
+
* [http://audacity.sourceforge.net/help/ Official Audacity Help Page] - includes FAQ, tips, and tutorials.
  * [http://quicktoots.linuxaudio.org/toots/audacity/ "An Audacity Tutorial" by Daniel James]
+
* [http://quicktoots.linuxaudio.org/toots/audacity/ "An Audacity Tutorial" by Daniel James]
  * [http://www.linux.com/articles/52956?tid=75&tid=130/ "Mastering Podcasts with Audacity" by Johnathon Williams] ("mastering" means post-processing)
+
* [http://www.linux.com/articles/52956?tid=75&tid=130/ "Mastering Podcasts with Audacity" by Johnathon Williams] ("mastering" means post-processing)
  * [http://www.how-to-podcast-tutorial.com/17-audacity-tutorial.htm "Audacity Tutorial for Podcasters" by Jason van Orden] - video tutorials
+
* [http://www.how-to-podcast-tutorial.com/17-audacity-tutorial.htm "Audacity Tutorial for Podcasters" by Jason van Orden] - video tutorials
  * [http://en.wikipedia.org/wiki/Audacity Wikipedia: Audacity]
+
* [http://en.wikipedia.org/wiki/Audacity Wikipedia: Audacity]

Latest revision as of 08:59, 18 June 2020

What is Audacity?

Audacity is a free, open source software for recording and editing sound. It is available for Mac OS X, Microsoft Windows, and Linux. This FAQ should hopefully get you started. If you have other questions feel free to post in the LibriVox Forums

How do I get Audacity?

You can download Audacity from their Web site. One you've downloaded Audacity, install it.

How do I get the LAME MP3 encoder?

You will also need the LAME MP3 encoder. It is a free, open source plug-in used to create (encode) MP3 files from your recordings. You can download it from here:

  • LAME download page - Take care to download the correct version for your operating system!

Once you've downloaded the LAME encoder, install it:

  1. Double-click on the file you downloaded to unzip it.
  2. You should see a file called lame_enc.dll. Copy this file to your hard drive. A good location is the folder where Audacity was installed.
  3. Make sure you remember where you put lame_enc.dll, because you will need to know this later.

Audacity Setup

Before you begin recording you will need to configure (set up) Audacity.

  1. File > Preferences ... example
  2. Audio I/O Tab > Recording Device ... example
  3. Audio I/O Tab > Recording Device chosen ... example
  4. Audio I/O Tab > Channels > 1 (Mono) ... example
  5. Quality > Default Sample Rate: 44100 Hz
  6. Quality > Default Sample Format: 16-bit
  7. Save your preferences by clicking OK

How to set your preferences

  1. Go to "edit" > "preferences" > "file formats" Check "Make a copy of the file before editing"
  2. Go to "Directories" check "auto save" Set to save every 5 mins.


How do I configure Audacity to find and use the LAME encoder plug-in?

Now that you've installed the LAME encoder (see above), you need to integrate it into Audacity.

  1. Start Audacity
  2. Edit > Preferences
    1. Import/Export tag > MP3 Export Library
  3. Click Find Library
  4. Read the message, then click Yes and browse to wherever you installed the file lame_enc.dll
  5. Select the file, and click the OK button
    1. Set the bitrate the first time you export to mp3 by going to:
      1. File > Export
      2. Save as type: MP3 Files
      3. Format Options... (below the cancel button)
      4. Bit Rate Mode > select the Constant radio button
      5. Quality > select 128 kbps from the drop down menu
      6. OK > Save

If you recorded on tape and want to transfer to your computer you can also use Audacity. Use the same settings as above except you choose Stereo for Channels and mark the box labelled Software Playthrough... example

How do I Start Recording?

Click the round red button to start recording. If you want to take a break and hit Stop (Yellow square), the next time you hit Record again it will start a new track; this is the normal behavior for Audacity. If you don't want to record on multiple tracks in this way, hit the Pause (Two parallel vertical stripes) button instead.

How do I save?

When you save in Audacity it creates an AUP (AUdacity Project) file. These aren't very useful for sharing, but it is a good intermediate format to use while you are editing. An AUP maintains all the tracks that you have from starting and stopping the recording. If you would like to collapse all these tracks together you can choose File > Export to WAV. This will create a new file which has only one track. If you open this file in Audacity it would be easier to edit. We encourage you to save often!

What if I made mistakes?

When you make mistakes it's usually easier to just re-record the section you want immediately. You can tap the microphone base a few times before re-recording so that it is easier to see where you need to make the edits. Do not tap the microphone itself as this can damage it. Other readers also say "pickup" or click their tongue. Whatever method you use just makes it easier to see edit points.

  1. Result of tapping on microphone (or tongue click) ... example
  2. Select a portion of your recording to edit: Click and Drag ... example
  3. Delete the selected portion of your recording. Hit the "Delete" key on your keyboard.

(You might want to look at Deleting Errors in Audacity, too.)

Can I clean up background noise?

Go here for the --> Audacity Noise Cleaning Tutorial

Should I record in Mono or Stereo?

Audacity allows you to choose Stereo or Mono when you start your recording. Since most of us don't use Stereo microphones, choose Mono. When you export the file it will end up playing back in Stereo. Recording in Mono just instructs Audacity to apply the same content to both left and right.

Why does my MP3 export as Stereo, when I am recording in Mono?

First make absolutely sure that you have set your recording preferences as Mono in Edit | Preferences | Devices | Recording | Channels, and that you have selected Joint Stereo as the Channel mode in the Options when you export the MP3.

If both of these are correct, and you are still told that your MP3 is Stereo, there is only one explanation that we have found: in Audacity, you will see a slider to the left of your mono track which looks like this: Leftright.png. If this is not correctly centred, then (for some inexplicable reason) Audacity will export your MP3 as a Stereo file.

How can I merge multiple tracks into a single one?

If you want to add background sounds or create a crowd scene: Merging Tracks

Additional Resources

Some additional guides on how to use Audacity (links working as of 2009 March):