How to Add or Edit ID3 Tags

From Librivox Wiki
Jump to: navigation, search
Related Topic: What is ID3.

This page lists various software packages and outlines how to add or edit ID3 tags with them. Scroll down to find the audio software you are using for your recordings.

  • If your software is not listed here and you know how to add/edit ID3 tags, please update this page (leaving the order alphabetical).
  • If your software is not listed here and you don't know how to add/edit ID3 tags, please post a message in our Need Help forum.

Notice that individual programs vary in which particular fields of the ID3 tag they give access to.

Regardless of which program you use, this is a video explaining where to find the exact stuff you should use to fill in the 3 fields LibriVox uses: What To Put into ID3 Spaces

Contents

Audacity

Ver 1.3 & later: Go to the File menu, then Open Metadata Editor. (Fill in ID3v2 window). If you would like to be prompted for ID3 info whenever you save an MP3, go to Edit, Preferences, Batch and tick/check Show MP3/ID3 dialog.

Earlier versions: When you click Export as .mp3 from the File menu, a little window automagically opens that asks you for the ID3 tag information.

Alternately, click Edit ID3 Tags... from the Project menu to bring up the same window. If you make multiple recordings in a row by exporting the first, closing the tracks, recording the second selection and exporting again, Audacity will retain the ID3 tags from the initial export rather than asking you for new ones, so in this case you will have to edit the tags through the Project menu before exporting the second time.

Ubuntu

Audacity for Ubuntu automatically generates ID3v2.4 tags which often are not visible in other applications in other operating systems. Librox uses ID3v2.3 tags. A single command in the terminal window can convert your ID3v2.4 tags to ID3v2.3 tags.

A program called eyeD3 is available through the Synaptic Package Manager. To install it go to System -> Administration -> Synaptic Package Manager. Enter your password when asked for it. In the search box type eyeD3. Click the box to the left of the program and mark for installation when prompted. Click the "Apply" button. If it suggests other dependent packages accept their installation also.

Once installed, open a terminal window by pressing Ctrl-Alt-T. At the $ prompt type:

eyeD3 --to-v2.3 /home/username/path/to/file/yourfilename.mp3

and press enter.

"username" is your computer username, "path/to/file" is the directory path to where you've saved the file, "yourfilename" is the required Librivox file name for your project.

This is an example of one of mine: eyeD3 --to-v2.3 /home/me/Desktop/Librivox/OmarResung/omarresung_5_blanden.mp3

On my Desktop, I have a folder called Librivox. Within that folder I create a folder for each project, this one was OmarResung. And in it is my .mp3 file.

Ubuntu commands and file names are case-sensitive so be sure to use upper-case to match the names exactly.

An alternative to converting is to NOT use Audacity for entering your ID3 tags. A GUI program called EasyTAG is available in the Synaptic Package Manager. With EasyTAG it is possible to set the version of your ID3 tags under Settings -> Preferences before entering them. This program can be installed in the same way as eyeD3 and once installed is found in the menu under Applications -> Sound & Video -> EasyTAG.

Cool Edit 2000, Cool Edit Pro

These probably also apply to Adobe Audition.

This assumes you have a Wave file open in Cool Edit and are ready to save it to MP3 format.

  • "View" [menu] > "Info..."
    The "Wave Information" dialog opens.
    • Select "MP3 (ID3 Tag)" from the pull-down menu to the right of "Text Field Names".
    • Fill in the fields as appropriate.
      • Set "Genre" to "Speech" for !LibriVox recordings.
    • Click the "OK" button when done to close the dialog

So now you've told Cool Edit what to put in the ID3 tag. Now it's time to create the MP3 file.

  • "File" [menu] > "Save As..."
    The "Save Waveform As" dialog
    • Select "MPEG 3 (FhG) (*.mp3)" from the "Save as type" pull-down menu.
    • Fill in "File name" as appropriate.
    • Check "Save extra non-audio information" (ie, "Fill in the ID3 tag").
    • Click the "Options..." button. The "MPEG-1 Layer 3 [MP3] Encoder Options" dialog opens.
      • Click the [:Glossary#wave: CBR] radio button.
      • Check "Convert to Mono" if it's enabled.
      • Select "128 Kbps, 44100 Hz ..." from the pull-down menu below "CBR (Constant Bitrate)".
      • Click the "Advanced>>" button if visible.
        • Uncheck the three "Set ..." checkboxes.
        • Uncheck "Write CRC Checksum".
      • Click the "OK" button to close the dialog
    • Click the "Save" button to create the MP3 file.
  • You may get the "Saving to Lower Fidelity Format" warning. This is normal: Click the "OK" button.

A caution: The next time you work on a Wave file and want to save it (as Wave), make certain to uncheck "Save extra non-audio information" before you save. The reason is that otherwise (with this option checked) the file you save will not be in plain, standard Wave format, because of the "extra" information that will be put inside it.

Exact Audio Copy

Exact Audio Copy has an ID3 tag editor for MP3 files, but notice this stated limitation:

"This ID3 tag editor will only edit and store ID3v1 tags. If there are additional V2 tags in the file, they remain unchanged. That way the two tags may show different data! So in that case use a V2 editor to copy the V1 to V2, or use it directly [to] edit both tags in one go."

This instruction assumes you have an MP3 file and want to add or modify its ID3 tag:

  • "Tools" [menu] > "Edit ID3 tags..."
    The "Select Files to Tag" dialog opens (essentially, the file "Open" dialog).
    • Navigate to the file you want to change and open it.
      The "ID3 Tag Editor" dialog opens.
    • Fill in the fields as appropriate.
      • Set "Genre" to "Speech" for !LibriVox recordings.
    • Click the "OK" button when done to close the dialog and save the file.

GarageBand

The latest version of GarageBand gives you the choice of exporting a file as either an AIFF or an MP3. Use GB Prefereneces to create the basic tags. Once exported to an MP3 file, you can edit those tags in any Mac application or utility that allows tag editing. The most popular for doing this is iTunes, which is free. See the next section on iTunes for details on how to do this.

iTunes

Ctrl-click (or right-click) on the track(s) in iTunes and select "Get Info" from the pop-up menu, and select the ‘Info’ tab from there. Edit the fields. Click OK.

As in Windows Explorer, you can edit multiple items. Select all the files you want to edit and then continue as above. The Name entry will be missing. All others will be blank if they differ within the files or displayed when they are the same for all selected files. You may have to accept some warnings about changing the information for multiple files.

You can select multiple files in iTunes by selecting the first one and then holding the CTRL-Key (Apple key on a Mac) down while selecting additional files (or, if the files are all next to each other, select the first and hold the Shift key whilst selecting the last).

MP3DirectCut

Open the Edit menu, and at the top is 'Tag ID3 and File Info'. Select that and a pop-up menu appears - tick/check the "Use ID3v1 tag" box, and then you can input the information.

Nullsoft Winamp Pro (v.5.1)

  1. Right-click the file name in the "now playing" pane.
  2. Click "View File Info" from the contextual menu.
  3. Click the check-box next to ID3v2 (on right side of dialog box).
  4. Enter the tag information in the appropriate fields.
  5. Click the Update button
  6. Dialog box will close automatically and tag editing is complete.

Alternate method to open tag editing dialog box:

  1. Select the file name in the "now playing" pane.
  2. Press Alt+3 keys on the keyboard.
  3. to 6.: same as above.

Note: You must Stop the playing of the file in order to edit its tag.

QuickTime Player

Select "Show Movie Properties", and go to the "Annotations" tab.

Sound Forge

In Sound Forge 10:

  • Do "Save As" and choose "mp3"
    • Check the check box toward the bottom that says "Save Metadata with File"
    • Before clicking "Save", Click on "Custom"
      • Set bit rate, etc.
      • Click on the "ID3 Settings" Tab, and enter your ID tags
        • Under Genre you cannot leave it blank, and have to choose something, even if it's "Other".

General consensus seems to be that editing tags with older versions of Sound Forge is not easy. The general advice is to use a third party tool, e.g. MP3Tag. (link back to relevant section on main ID3 page, which lists some tools)

Total Recorder

For ID3 tags, there are two ways to use Total Recorder. One is to fill in the tag when creating an MP3 file from a Wave file. The other is to add or edit the ID3 tag of an existing MP3 file.

These instructions assume you have a Wave file open in Total Recorder and are ready to save it to MP3 format:

  • "File" [menu] > "Save As..."
    The "Save As" dialog opens.
    • Click the "Change..." button.
      • Select "Mpeg Layer 3 [MP3] ..." from the "Format" pull-down menu.
      • Select "44100" from the "Sample rate" pull-down menu.
      • Click the "Mono" radio button for "Mode".
      • Click the "Constant bit rate" radio button under "Bit rate settings".
      • Select "128" from the "nominal" pull-down menu.
      • Select "High quality" from the "Quality" pull-down menu.
      • (Note that you can save these settings for later re-use with the "Save as..." button.)
      • Click the "OK" button to close the
    • Click the "More..." button.
      The "ID3 tag" dialog opens
      • Click the "MP3" radio button for "File header type".
      • Check both the "ID3v1" and "ID3v2" checkboxes.
        Fill in the ID3v2 set on the right side of the dialog.
        • Fill in the fields as appropriate.
          • Set "Genre" to "Speech" for !LibriVox recordings.
        • Click the "Copy from ID3v2 <<" button; this fills in the left side.
      • Click the "OK" button when done to close the dialog
    • Click the "Save" button to create the MP3 file.


This instruction assumes you have an MP3 file open and want to add or modify its ID3 tag:

  • "File" > "Tag..."
    This opens the "ID3 tag" editing dialog described above.
    • Fill in the tag as described above, starting at the point after "Click the "More..." button.
  • "File" > "Save" to save the file, after you close the "ID3 tag" dialog.

Windows Explorer

Yes, at least in Windows XP (SP2; earlier versions after Windows 98 unknown), Explorer can edit ID3 tags. A big advantage of this method over many others is that you can edit the tags of more than one file at a time, say, to standardize the album or artist for sets of related files (such as an audio book that comes in multiple files).

In Windows Explorer:

  • Right-click on the MP3 file.
  • Select "Properties" at the bottom of the pop-up context menu.
  • Click the "Summary" tab.
  • Click the "Advanced>>" button, if visible.
    You will see two columns, "Property" and "Value".
  • Click once on any value (even if blank), and a text entry box opens.
  • Type in the information.
  • Repeat previous two steps as necessary.
  • Click the "OK" button when finished.

Differing from iTunes, when you edit multiple files, a blank value for a field indicates there is no data in that field for any of the files. When there are different values in the same field for different files, you will see "(multiple values)" displayed for that field.

One drawback of this method is that occasionally Windows Explorer gets lost when I edit a large number of files at once, and I have to kill it with the Task Manager. But mostly it works just fine.

Personal tools